Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Debugger error "No file to debug"
Tried to run Embitz 1.11 on a plain standard Win8.1 install, project previously on Win7 worked just fine, on Win8.1 it compiles, no errors yet when
trying to run debug gives errors ""No file to debug"" and dont start debug session yet the elf, hex, map etc files are generated. Is this some
path dependency, link error etc?
Well it has something to do with the configuration of your project. Most likely absolute paths which are no longer there at the new machine.
Often with this you think, bloody hell why? And after you found it it was very obvious why it couldn't find the target .elf file.

Also, sometimes the linker will throw errors which are not captured by EmBitz because it has a non-conform format. Use the build messages to check if there is really a .elf file generated. This has also often to do with wrong paths etc.
Made a new Embitz 1.11 project using the default project setup and left all project settings as is created by Embitz then
manually copied all c and h files from that old project to the new, then manually checked every singe file, compiler, builder,
linker etc project paths , it compiles and builds just fine yet no file to debug. Ideas?

Building to ensure sources are up-to-date
Build succeeded
Selecting target:
Adding file: "F:\stm32f446ret audio4\bin\Debug\stm32f446ret audio4.elf"
No file to debug!

Edit: Could not stand win8.1 so its on win10 now, removed the space in the file name, it now seams to find the elf file, now try to start debug but then immediately closes debug session.

Forum Jump:

Users browsing this thread: 1 Guest(s)